My WordPress Posts Redirecting To Another Post

wordpress

(Tunde Sanusi (Tuham)) #1

Good day to you @jidetheblogger

Please am having issue with my wordpress website. When i click the link of a post on the blog section of my website, it redirects to another post instead…

What could be wrong?


(Jide Ogunsanya) #2

Is this affecting a specific link or all posts links?


(Emmanuel Ekanem) #3

Is it all the posts or something?


(Tunde Sanusi (Tuham)) #4

Not all posts link… Just few for now I guess two or three posts


(Tunde Sanusi (Tuham)) #5

Not all the posts…

For instance;

The article 7 Facts About Me With This Link >> https://www.tuhamworld.com/2015/11/7-facts-you-dont-know-about-tunde.html

Redirects to

Get A Virtual Debit Card Online >> https://www.tuhamworld.com/get-virtual-debit-card/


(Emmanuel Ekanem) #6

Hmm, this is a serious problem…

You sure didn’t set a redirection on those posts?


(Tunde Sanusi (Tuham)) #7

I’ve checked the Redirection Plugin several times and am double sure i didn’t set the Redirection

Infact I’ve tried deactivating the Redirection Plugin self… Still the same


(Emmanuel Ekanem) #8

Oops… Let’s wait and hear from @jidetheblogger, the might be something wrong somewhere.


(Jide Ogunsanya) #9

And have you checked your .htaccess file to see if redirections are not set in it? You can as well rename the htaccess file to .htaccess1 so that new .htaccess file can be generated for your blog automatically, after which you can check if the problem persists


(Tunde Sanusi (Tuham)) #10

Oohkay bro


(Tunde Sanusi (Tuham)) #11

I guess perhaps that’s where the fault might comes in… I remember a while again that i edit something in the cpanel… Would give this a try and see how it goes


(Emmanuel Ekanem) #12

Try it ASAP.


(Tunde Sanusi (Tuham)) #13

I just edit the .htaccess and re-create the default WordPress htaccess… The problem still persists :neutral_face:


(Jide Ogunsanya) #14

I said you should rename the existing htaccess file. Don’t create anyone by yourself. After you rename, just visit the blog and maybe go to permalink settings and click SAVE.


(Tunde Sanusi (Tuham)) #15

Oh i get it… And i just do that one too…

Still same…

Is like Village people mean me this time around :slightly_frowning_face:


(Emmanuel Ekanem) #16

ahh, this one is strong ooo


(Tunde Sanusi (Tuham)) #17

Very strong i swear…

It happens to only 1% of WordPress users… See another sample of someone >> https://stackoverflow.com/questions/34498207/wordpress-post-redirecting-to-another-post-when-it-shouldnt-be


(Tunde Sanusi (Tuham)) #18

dancing%20man

Its now working!!!


(Jide Ogunsanya) #19

So, that’s why you are now twerking abi? :grinning:

So, how did you fix it?


(Tunde Sanusi (Tuham)) #20

It deserve twerking my Ogbongebro :grinning::grinning::grinning:

I deactivate plugins one by one… Purge all caches… Change my permalinks settings to postname and then revert back… etc

I don’t know exactly what fixed it but all of all of your suggestion was part of the miracle :wink:

Thanks @RealityEmma @jidetheblogger you guys rocked