Blogger Blogs Using Custom Domain Not Opening

Blogger blogs using custom domains are not opening at my end.

ping blogger servers

Are you experiencing same?


Same ooo… Just confused what’s the problem.

I had a similar experience yesterday afternoon, but it’s okay now

@jidetheblogger the issue is with glo network on Firefox I think, @tuhamworld called my attention to it yesterday. Meanwhile blogger blogs are opening on other browsers.

1 Like

Even my own is not coming up…

But I used To browser and it opened

Oh! I think you’re right. I used glo network on the computer great yesterday’

Thanks for the clarification. Since you mentioned it open with MTN Network, i think the issue is with GLO then…

Funny enough, blogger subdomain are working fine like

plz how do you do it

opening i just checked

Mine is opening although I didn’t try with mozilla firefox

You’re using which network

Serious problem. Na wa ooo…

The ticket was closed… But the issue still persist

It’s opening from my end oo

I closed the private message thread, not this public post.

Can you access my blog from your end? If yes, with which network?

Yes. I’m using Airtel.

Please whats the way forward? Glo seems not letting my blogs connect, has it started working at your ends and with what network please. Really confused

Holy shit, thank God, i thought it’s a personal problem on my side, every blogger blog is not going on my end using chrome and some other browser, i tried ogbongeblog and ladun too, all the same… I can publish and preview post but can’t view blog… On chrome actually and i tried some other browser too, same thing except one browser. “Puffin Web Browser” i use that browser to access web that doesn’t give access to Nigeria without vpn… The browser is based in the US…

Every blogspot that’s not accessible through other browser, that browser opens them… And i use GLO tooo by the way…

So, are we suppose to stop using GLO or just sit duck and be patience till its fixed… Nawa o…

This mean every visitors using same network won’t be a able to access one’s blog, thinking its dead…